Student Relationship Management System

Incident Report for Athabasca University

Resolved

This incident has now been resolved. Case management is now functioning correctly.
Posted Oct 14, 2025 - 12:39 MDT

Investigating

We are currently investigating an issue with an error on case creation in the Student Relationship Management system.
Posted Oct 14, 2025 - 08:57 MDT
This incident affected: Staff Services & Supports.